Есть сегментик L2, нужно организовать резервирование и балансировку при отсутствии аварий.
Схемка включения:
Описание схемы включения.
Из Fa0/1 порта Cisco кабель уходит в 1 порт Dlink, далее из 8 порта Dlink в следующий Dlink в 1 порт и т.д..
В конечном итоге из 8 порта последнего порта Dlink в кольце приходим в Fa0/2 порт Cisco.
Настройка портов Cisco:
- Код: Выделить всё
interface FastEthernet0/1
port-type nni
switchport trunk allowed vlan 27,30
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
no cdp enable
end
- Код: Выделить всё
interface FastEthernet0/2
port-type nni
switchport trunk allowed vlan 27,30
switchport mode trunk
logging event trunk-status
logging event bundle-status
logging event spanning-tree
no cdp enable
spanning-tree mst 2 port-priority 64
end
Настройка портов Dlink(на всех коммутаторах в кольце):
- Код: Выделить всё
DES-2108:>show vlan
Command: show vlan
Asymmetric VLAN: Disable
Management VLAN: 30
VLAN_ID:1
VLAN name:default
MEMBER:
TAG PORT:
UNTAG PORT:
VLAN_ID:27
VLAN name:27
MEMBER:01 02 03 04 05 06 07 08
TAG PORT:01 08
UNTAG PORT:02 03 04 05 06 07
VLAN_ID:30
VLAN name:30
MEMBER:01 08
TAG PORT:01 08
UNTAG PORT:
Конфиг mst:
- Код: Выделить всё
!
spanning-tree mode mst
spanning-tree logging
spanning-tree extend system-id
!
spanning-tree mst configuration
name region1
revision 10
instance 1 vlan 1, 30
instance 2 vlan 27
!
Остальные порты Cisco настроены:
- Код: Выделить всё
spanning-tree portfast
spanning-tree bpdufilter enable
Вроде как всё верно настроил.
Собрал схему на столе, но правда с одним DLink, имею картину:
- Код: Выделить всё
cat.test2#show spanning-tree mst 0
##### MST0 vlans mapped: 2-26,28-29,31-4094
Bridge address 0022.bd11.7480 priority 32768 (32768 sysid 0)
Root this switch for the CIST
Operational hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured hello time 2 , forward delay 15, max age 20, max hops 20
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 200000 128.3 P2p
Fa0/2 Back BLK 200000 128.4 P2p
cat.test2#show spanning-tree mst 1
##### MST1 vlans mapped: 1,30
Bridge address 0022.bd11.7480 priority 32769 (32768 sysid 1)
Root this switch for MST1
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 200000 128.3 P2p
Fa0/2 Back BLK 200000 128.4 P2p
cat.test2#show spanning-tree mst 2
##### MST2 vlans mapped: 27
Bridge address 0022.bd11.7480 priority 32770 (32768 sysid 2)
Root this switch for MST2
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Back BLK 200000 128.3 P2p
Fa0/2 Desg FWD 200000 64.4 P2p
Всё отлично работает, как я и хотел.
Теперь рабочая схема, не работает как на столе
Вот что имею:
- Код: Выделить всё
##### MST0 vlans mapped: 2-26,28-29,31-4094
Bridge address 0022.bd11.ec00 priority 32768 (32768 sysid 0)
Root this switch for the CIST
Operational hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured hello time 2 , forward delay 15, max age 20, max hops 25
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 200000 128.3 P2p Bound(PVST)
Fa0/2 Desg BKN*200000 128.4 P2p Bound(PVST) *PVST_Inc
Fa0/3 Desg FWD 200000 128.5 Edge P2p
Fa0/24 Desg FWD 200000 128.26 P2p
##### MST1 vlans mapped: 1,30
Bridge address 0022.bd11.ec00 priority 32769 (32768 sysid 1)
Root this switch for MST1
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 200000 128.3 P2p Bound(PVST)
Fa0/2 Desg BKN*200000 128.4 P2p Bound(PVST) *PVST_Inc
Fa0/24 Desg FWD 200000 128.26 P2p
##### MST2 vlans mapped: 27
Bridge address 0022.bd11.ec00 priority 32770 (32768 sysid 2)
Root this switch for MST2
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 200000 128.3 P2p Bound(PVST)
Fa0/2 Desg BKN*200000 64.4 P2p Bound(PVST) *PVST_Inc
Fa0/24 Desg FWD 200000 128.26 P2p
Искал полезную информацию на Cisco, нашёл по теме Bound.
Boundary Ports
In the Cisco prestandard implementation, a boundary port connects an MST region to a single spanning-tree region running RSTP, to a single spanning-tree region running PVST+ or rapid PVST+, or to another MST region with a different MST configuration. A boundary port also connects to a LAN, the designated switch of which is either a single spanning-tree switch or a switch with a different MST configuration.
Вопрос, почему?
Рад любому совету.